Issue:
Some users may encounter missing or incorrect rollup field data in Breadwinner.
Root Causes:
Two primary reasons often lead to problems updating rollup fields during the Breadwinner Sync process:
Validation Rules: Existing validation rules within your Salesforce environment might interfere with the rollup field update process. If the conditions of these rules are not met, they can trigger and block the update during the Breadwinner sync process, resulting in errors and missing or incorrect Rollup fields data.
Custom Automations: Automations such as Flows, Process Builders, or Apex triggers linked to the Account and Opportunity objects may trigger and stop the Rollup fields update/sync process if the automation criteria are not met.
Troubleshooting Steps:
Check Breadwinner Status Logs for Errors:
Go to the “Breadwinner Setup” page within your Salesforce org.
Navigate to the “Troubleshoot” section.
Go to the “Status logs” and click on the button “Check Log for Recent Errors”.
Review the error logs for entries related to the Account or Opportunity Rollup errors. These often point directly to validation errors or automation conflicts.
Review Salesforce Validation Rules:
Go to Setup → Object Manager → select Account or Opportunity object based on the Status log error message.
Open Validation Rules and check for any rules that could block updates.
According to the Validation rule, please maintain/adjust the value in the related object records to avoid data discrepancies.
Or temporarily deactivate or modify potentially conflicting rules to see if it resolves the issue. If it does, carefully adjust the rule conditions to allow the rollup field updation.
Inspect Custom Automations:
If the error messages indicate that the issue is caused by Flows, Workflow Rules, or other automations, review the automation logic configured on the relevant objects (e.g., Account or Opportunity), and check whether the automation depends on fields that Breadwinner modifies/updates.
Restart the Sync Process manually:
After verifying the above points and resolving the issue, please restart the Breadwinner "Update Account and Opportunity Rollups" button from General under the Troubleshoot section on the Breadwinner Setup page to update the missing data on the Rollup fields.
Escalation: Contact Breadwinner Support
If you have completed these steps and are still experiencing issues, contact Breadwinner Support at help@breadwinner.com or support@breadwinner.com with the following information:
Detailed description of the error message (if any).
If this is a technical issue, provide the customer's name and Salesforce Org ID and grant login access to your Salesforce org.
Please provide the affected records to check the issue, or share screenshots illustrating the issue.
Additional Notes:
It is always a good practice to test changes, such as deactivating validation rules, in a sandbox environment before making changes to production.
Breadwinner Support is available via a dedicated support portal that uses the Salesforce Service Cloud to manage support cases.
If you receive an email response from Breadwinner Support, please be sure to stay in the same support email thread by replying to the email you received.